1 (edited by Lemon_Newton-Metre 2021-04-19 06:21 AM)

Topic: Short diagnosis: 87/88 M-B 300TD [resolved]

Red 'battery' light on dash while running; also when key is off if the battery is still connected.
A battery disconnect works around the current problem, but doesn't solve it.
I have not left it for a reasonably short time to see if it turns off, like automatic headlights.
The light is brighter when accelerating (higher revs); think the alternator's working? But:
Over a ~20 min. driving time, the battery's voltage dropped from the time of first idling until I stopped driving it around the parking lot and parked it again.
Runs and drives; dead battery next time if left connected for a month.
Runs rough at low revs, runs smooth at higher revs.
Apparently sat for several years; rodent nest (which has been removed) near the battery tray and center rear of the engine compartment. No visible chewed wires, and no visible burned rodents.
3 rows of fuses in the fuse box.  Pulled each fuse sequentially with engine off; 'battery' light stayed on for each fuse, with no perceived change in intensity - though it was very sunny out, and the light was hard to see. I returned each row's fuses before I started on the next row.
Disconnected ground wire with engine off - light goes out - this is to the right shock tower.  There's another pair of wires (from I don't know what) grounded there as well (see pic); no change when disconnected.

Multi-meter: voltage tested the Alternator (remanufactured at some point fairly recently). 3 contacts on the connector; when grounded to the alternator's case, two register a steady 12.24 VDC, the third registers 16.20. Is the Alternator bad?

Thinking of disconnecting the ground wire with the car running, or the positive.

Is the 'battery' light a _general_ electrical/charging system trouble light?

Any suggestions where to look next - like another main ground connection at the engine?

Engine bay:
https://i.postimg.cc/zf1yjDj0/20210415-173924.jpg

Battery, ground:
https://i.postimg.cc/SQZzhhSx/20210415-173932.jpg

Fuses:
https://i.postimg.cc/pr19YDGF/20210410-204258.jpg

Alternator plug:
https://i.postimg.cc/MKvfZFHb/20210415-173051.jpg


And yes, I know: "You said it runs - pull the crappy 33 year old interior and you'll find the short; then cage it and race it'.


First things first...

2 (edited by Team Infinniti 2021-04-16 05:23 AM)

Re: Short diagnosis: 87/88 M-B 300TD [resolved]

Pull the alt and have it tested, it may have a shorted diode.

Homestead Chump 5th-Sebring 6th-PBIR Lemons 9th - Charlotte Chump  CrashnBurn 9th
Sebring 6th again -NOLA Chump 1st -PBIR Chump Trans Fail 16th
Daytona 11th - Sebring 6th - Atlanta Motor Speedway 2nd - Road Atlanta Trans Fail 61st-Road Atlanta 5th
Daytona 13th - Charlotte 9th - Sebring 2nd-Charlotte 25th broken brakes - Road Atlanta 14 10th-Daytona 14  58th- Humid TT 19th Judges' Choice!

Re: Short diagnosis: 87/88 M-B 300TD [resolved]

I agree with Team Infinniti.

To answer your question, the logic of the battery light depends on the car, and sometimes the brand of alternator, but it should go off within a second after you start the engine. Some battery lights are just an indication that the voltage is below the normal charging voltage for a battery, some light up when the voltage at the alternator is not greater than the voltage at the battery, and some are connected to the voltage regulator in the alternator, and light up when the watchdog function decides that there is a problem.

The one way to tell if your battery is charging, (assuming you don't have a clamp meter) is to measure the voltage at the battery before starting the engine, and again once the engine is running. The voltage before will tell you how discharged your battery is, and if the voltage is higher when the engine is running, then you can tell that the alternator is adding power to the system, even if isn't really charging the battery.

12.24 V is below the normal voltage of a charging lead-acid battery and 16.20 V is way above, so it's pretty likely something is broken with your alternator, but if it's a fairly weak alternator and that large group 49 battery is quite discharged and able to suck down all of the power from the alternator, then it's theoretically possible that the battery could be pulling the voltage down to 12.24 V when it's charging.

If you measure 16 V at the battery when it's running: shut it off; that's bad for the battery.

Re: Short diagnosis: 87/88 M-B 300TD [resolved]

For a 3 wire alternator, the battery light 'excites' the alternator so that it starts generating electricity.  On my 80's Volvo it was wired to a +12v hot connection on the ignition switch that is not fused, from there it goes to the D+ terminal on the alternator.  When you put the key in and turn it to the on position, power from the battery goes through the bulb to the alternator. Since the alternator is not generating current, the bulb turns on.  Once you start the car, the small amount of current from the battery goes through the bulb and starts the alternator generating current. Since there is  about +12v on both bulb connections, it turns off.

Fairly standard setup in older cars.

Re: Short diagnosis: 87/88 M-B 300TD [resolved]

Red 'battery' light on dash while running; also when key is off if the battery is still connected.

Key off should take the alternator out of the equation (though pulling the alternator is definitely on the list because of the unexpected voltages).

That, and the brighter light when accelerating, is what confuses me.

The 2-yr old battery (from a separate vehicle) was fully charged before I started this diagnosis.

There's also a fusible link on the driver's side with a wire going into the fusebox which I disconnected with no change - I forgot to mention that; sorry. And: I pulled the wire from each side of the mounting point separately; still no change.

That should have removed every system run through the fusebox all at once, not just individually or by row.

I was trying to figure out what sort of logic would be required - other than there's a short someplace - to over-engineer a 'charging system' warning light to go on in a case such as this.

I can theorize a defective remote lock system or anti-theft system drawing some power constantly which might light a warning. Maybe the light goes out after a minute or so - I don't know, I didn't think to check the first three times I looked at this (I might be completely off-base with this idea).

I'm still thinking a short-to-ground. Or some system that's set to "ON" that maybe shouldn't be.

With - likely - a defective alternator compounding the issue.

6 (edited by Lemon_Newton-Metre 2021-04-16 08:04 AM)

Re: Short diagnosis: 87/88 M-B 300TD [resolved]

(deleted - my wrong interpretation)

7 (edited by Lemon_Newton-Metre 2021-04-19 06:21 AM)

Re: Short diagnosis: 87/88 M-B 300TD [resolved]

Two leads from the positive terminal; thinner one drops to a 3- terminal bus right behind the shock tower.
I removed this wire and the light went out:

https://i.postimg.cc/fWjt8Bf7/20210417-143604.jpg

Came back yesterday to a completely dead battery.

Yes, I apparently disconnected the wire that powers the battery light.

The draw is via the thicker pair of wires on the center terminal, and I can trace those no problem.

I also found benzworld - they've posted all the manuals, including electrical diagnosis manual, apparently complete.

I'll deal with the alternator after I isolate the dead short. Thanks for your help - greatly appreciated.